Chromium on Gentoo Linux running Smooth!

Ok, I had to do it and the result is nice. Chromium (the Google Browser) on my Gentoo Linux Box runs very nice. This is how you get there if you are on Gentoo-Linux:

http://code.google.com/p/chromium/issues/detail?id=13425

Grab the custom Ebuild from here:

http://sources.gentoo.org/viewcvs.py/gentoo-x86/www-client/chromium-bin/chromium-bin-0_p17178.ebuild?view=markup

Enjoy!

HD Intel SSD Flash 160GB X25-M with Gentoo running Smooth

Ok, because of this post I had to try a Intel SSD. So I bought this one here. I moved all my data over like this. It all worked well and now I am running on my new SSD. And there is a big difference. So a quote from here is totally true:

If you’re curious, it’s the random write performance that you’re most likely to notice and that’s where a good SSD can really shine; you write 4KB files far more often than you do 2MB files while using your machine.

Also Startup-Time of your computer is crazy fast! I can hardly see my Gentoo-Message while BootUp anymore. If your are on Linux, also consider these options for fstab and booutup: noatime, elevator=noop. But read more of your own in the above mentioned links.

Update: There is a newer, faster and cheaper version out now: X25-M G2

Testing EC2 from Amazon by Building a Custom Image (AMI)

1. Ok, so I decided to try out EC2. The first thing – obviously – what you want to do is, build your own custom image. First Bummer: Amazon will not allow you to build and compile your own kernel! You will have to use an Amazon-Kernel found here. At the moment I am compiling Gentoo (amd64) according to this HowTo.

While my Gentoo compiles, some of the points I do not like about Amazons Communications:

  • What is the underlying hardware they are using?
  • What CPU’s do you get for your money, what is their speed? I tried to find out myself by doing “cat /proc/cpuinfo”
  • What kind of disks are the different instances running on? Are they SATA, SCSI, IDE, etc?

I really would love to see more transparency in above points by Amazon.

2. Somehow I also have the feeling that the “value for money” you get from Amazon EC2 for using their CPU’s is expensive (like buying a car vs leasing a car; leasing a car is always more expensive). The reason why I have this feeling is because I compared the prices for buying a server equivalent of the m1.xlarge instance. The price for such a server would roughly be USD 3000.-. Now traffic is cheap at EC2 but CPU’s are not. EC2 will give you comparingly “slow” CPU for your money if you compare to buying a new server. “cat /proc/cpuinfo” for the m1.xlarge instance shows me “Dual Core AMD Opteron(tm) Processor 270” processor.

3. Doing a “emerge -e world” – on a “m1.large” instance – and at the same time untaring the linux-2.6.16.33-ec2.tgz makes the “untaring” take forever (more then 50 Minutes). Just for unpacking 53 MB. Is it possible that XEN still has some problems juggling the resources of an instance? I get the feeling that my instance only gets the CPU “to do one task at the same time”.

4. Ok, so now I started surfing the web about more detailed Feedback (also negative) on EC2 an I found the following to links:

and I must say that I am stopping my experiment right here. And yes, this is _totally_true_: “And I get a bit irritated when I come across sentences like Jinesh’s at RailsConf: “infinity auto-scalable on-demand computing resource”” – but just go an check it out for yourself! EC2 of Amazon is definitely still BETA.

Qemu rocks my Balls off! Oh my God!

I just installed the latest version of Qemu on my Gentoo machine and I am impressed how easy the installation was. I am really impressed. I did not have to configure any interface or stuff, I just installed Qemu Version 0.9.1 and also KQemu (1.3.0 pre11) put in the CD of my Windows XP copy and ran these commands:

$ qemu-img create -f qcow2 /path/to/xp.cow 1300M

$ qemu -hda /path/to/xp.cow -boot d -cdrom /dev/cdrom -m 384 -localtime

and then to boot into my XP from my Gentoo:

$ qemu -hda /path/to/xp.cow -boot c -m 1000 -localtime -k de -usb -soundhw all

Man, Fabrice Bellard I am just a bit baffeled how easy and smooth this went. Thank you!

OMG: Sound works as well.

This is far more easy to install then VirtualBox for me. Vista does not work yet though at least not during my last try.

Vista-Qemu-Update:

Vista does not want to install. I get following error:

qemu acpi vista error

I googled and this seems to be an ACPI related error. Maybe my Bios does not fully support ACPI to the satisfaction of Windows Vista.

Update: There seems to be a solution for this problem, I just searched the qemu-mailinglist-archives.

Update 10.4.2008: Guess what, now it works quite smooth! Just installing Windows Vista on my Qemu-Gentoo.